Mapilio_kit: error: 'NoneType' object is not subscriptable


I’m trying to upload images using mapilio_kit for the first time, but has run into an issue.

I’m running Ubuntu 23.10, has installed mapilio_kit in a Python3 venv and run mapilio_kit authenticate with success.

But when I try to upload images I get a Python error:

(mapilio_kit) tryl@sofie:~/synology/streetcam/mapillio/mapilio-kit$ mapilio_kit upload ~/synology/streetcam/mapillio/2017-05-07/garmin-0deg/0/success/
metadata properties being processed:   0%|                                                                                                                  | 0/874 [00:00<?, ?files/s]
usage: mapilio_kit [-h] [--version] {upload,decompose,authenticate,video_upload,image_and_csv_upload,CSVprocessor,gopro360max_process,zip,run} ...
mapilio_kit: error: 'NoneType' object is not subscriptable

My images are geotagged, but I get the error both when I try to upload and decompose and upload via mapilio_kit run.

I also tried cloning the git repository and running setup: Same result.

If there just was a stack trace I might be able to track it down. Any good idears? A fix, how to run mapilio_kit in a development mode?

Best regards, Simon


Could you kindly provide a sample folder you are attempting to upload using the kit to We would like to investigate any potential issues with our upload functionality.

Thanks, I have sent an e-mail with 3 files on which the issue is reproduced.


I hope this message finds you well. I wanted to inform you that the upload issue you reported has been successfully resolved. Our team has implemented a fix, and you should now be able to upload without any issues.

We appreciate your patience during this process. If you encounter any further issues or have additional questions, please don’t hesitate to reach out to our support team at and .

Thank you for your understanding.

Best regards,

1 Like